Welcome Guest. Please Login or Register  


You are here: Index > Advanced Electron Forums > Themes and skins > Topic : Editor doesn't show cursor in Firefox

A2 Hosting

News:

Group Message
Hello Guest,

Welcome to the AEF Board. AEF is getting better and better and is also becoming more popular.
Take a few seconds to Register, its free, and it inspires us to work harder and improve on whatever we can improve on.
Give us some feedback, and tell your buddies about AEF!

Thanks,
The AEF Team



Threaded Mode | Print  

 Editor doesn't show cursor in Firefox (3 Replies, Read 11045 times)
Brendon
Group: Member
Post Group: Newbie
Posts: 2
Status:
Hi,

I was going to post this in "Bugs", but I thought this would be a more suitable forum for it.

My problem is that (with the default theme) I can not "select" the textarea when using Firefox - the cursor doesn't appear, but I can still write text. This is a bit annoying as I can't see where I am typing.

I have created this "work-around" for anyone who is interested. Simply open up /themes/default/js/texteditor.js. Look for the following:

Code
<style>p{margin: 1px; padding: 0px;} img{border: 0px solid #000000;vertical-align: middle;}</style>


Just simply replace it with:

Code
<style>body {  height: 169px; }p{margin: 1px; padding: 0px;} img{border: 0px solid #000000;vertical-align: middle;}</style>


And the area becomes selectable. The problem was that Firefox set the document's height to 0 (because it had no content), which means clicks weren't captured outside of these bounds.

Thanks,
-Brendon.
IP: --   

Editor doesn't show cursor in Firefox
Brendon
Group: Member
Post Group: Newbie
Posts: 2
Status:
Sorry, just discovered an issue with my first fix. This code works better:

Code
<style>body {  min-height: 169px;height: auto !important;height: 169px; }p{margin: 1px; padding: 0px;} img{border: 0px solid #000000;vertical-align: middle;}</style>


Allows the area to change height when more than 169px-worth of lines is entered.

-Brendon.
IP: --   

Editor doesn't show cursor in Firefox
Joshy
Group: Member
Post Group: Super Member
Posts: 671
Status:

Head of AEF Themers
It also has to do with the default editor. I can't remember it off the top of my head something like the WYSIYG or something editor. If you disable this editor it should start showing your cursor.

-----------------------
Maybe if I just drink half, I'll be half buzzed for half the time, who's the master mind behind that little line.

IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Members who read this topic
jlhaslip, Joshy, orange-clip, Maro, yrina, mjocika, fbforum, riccy7422, dr17, aryan, Brendon, Pico4U, haydenbrown, Jars, dreaken, warminster, ctgo, tj111, LW1, Copykat, lirika, trikiano, LMB, rudolf, vietthoai, cristrixy, harmail, Kim_Smith, seema123


Users viewing this topic
1 guests, 0 users.

A2 Hosting

All times are GMT. The time now is October 20, 2019, 10:04 pm.

  Powered By AEF 1.1.0 Preview © 2007-2011 AEF Group. All rights reservedQueries: 13  |  Page Created In:0.043