Welcome Guest. Please Login or Register  


You are here: Index > Advanced Electron Forums > Languages and International Support > Topic : Polish language


News:

Group Message
Hello Guest,

Welcome to the AEF Board. AEF is getting better and better and is also becoming more popular.
Take a few seconds to Register, its free, and it inspires us to work harder and improve on whatever we can improve on.
Give us some feedback, and tell your buddies about AEF!

Thanks,
The AEF Team

1


Threaded Mode | Print  

 Polish language, problem with encoding (25 Replies, Read 302530 times)
tommass
Group: Member
Post Group: Newbie
Posts: 5
Status:
Hi!

J want to translate AEF on polish language.
This language uses special characters.
How to change an encoding, to see this characters?
In this moment I translated one file and forum is not working. When I go back to oryginal english file, everything is ok.
IP: --   

Polish language
pulkit
Group: Administrator
Post Group: Super Member
Posts: 2396
Status:
Which character set do you want to use ?

-----------------------
Board Image

AEF now featuring in Softaculous - Auto Installer : http://www.softaculous.com
Rate for AEF - http://www.softaculous.com/softwares/forums/AEF
IP: --   

Polish language
tommass
Group: Member
Post Group: Newbie
Posts: 5
Status:
ISO-8859-2 will be perfect.

I think, utf-8 will be good too.
IP: --   

Polish language
atsuki
Group: Member
Post Group: Newbie
Posts: 12
Status:
How the progress of translation? Jak mozna spytac :)

-----------------------------
Edit:

In hl_themes.php you mast change encoding to iso 8859-2 and the traslation file you mast convert to iso 8859-2. It works :)

Maybe we will merge our efforts? :)


Edited by atsuki : March 15, 2008, 5:06 pm
IP: --   

Polish language
tommass
Group: Member
Post Group: Newbie
Posts: 5
Status:
J still have problem with encoding. It's no sense to do it, before I find the way, to see the special characters.
Znaczy ze jak znajde sposob na polskie znaki, to zabiore sie za robote. :)
IP: --   

Polish language
atsuki
Group: Member
Post Group: Newbie
Posts: 12
Status:
Ok.. so. How to make polish translation to work i AEF I know.. but I have another problem (see http://aef.krecio.pl/alpha/ ) Category name, text in forum option.. without PL characters, also in post.. :( (test here: ąśćęłź)/edit: it works ^^


Edited by atsuki : March 16, 2008, 11:19 pm
IP: --   

Polish language
tommass
Group: Member
Post Group: Newbie
Posts: 5
Status:
I'm sorry for everybody, who don't understand Polish. But speeking in barbarian languages, is not my best. ;)

Słuchaj, wszystko co napiszemy w postach ląduje w bazie danych. Jeśli ta baza jest w UTF-8, to będziemy widzieli polskie znaki w postach i wszędzie gdzie user coś wpisuje. Problem jest ze zrobieniem tłumaczenia plików forum. Jak wrzucam polskie znaki to forum pada... Nie wiem co z tym zrobić.
IP: --   

Polish language
tommy
Group: Member
Post Group: Newbie
Posts: 46
Status:
Quote From : atsuki March 15, 2008, 9:41 pm
Ok.. so. How to make polish translation to work i AEF I know.. but I have another problem (see http://atsuki.in5.pl/forum/) Category name, text in forum option.. without PL characters, also in post.. :( (test here: ąśćęłź)/edit: it works ^^


Read through this thread and you'll find the answer: http://www.anelectron.com/board/index.php?tid=429&tpg=2

AEF not yet support utf-8 encoding


-----------------------
Webmaster forum
Drupal themes
IP: --   

Polish language
atsuki
Group: Member
Post Group: Newbie
Posts: 12
Status:
But I not talking about utf-8 .. iso-8859-2 will be good as well.


Edited by atsuki : March 16, 2008, 11:42 pm
IP: --   

Polish language
umitkenan
Group: Member
Post Group: Newbie
Posts: 4
Status:
Hi,

I think, your problem is PHP's HTMLENTITIES function. It is used for cleaning some unwanted characters (for security). But this functions support only English characters.

Your entries encoded to 8859-1 first, then the new entry encoded again (this time, encoded to utf-8).

If you change 148th line of functions.php with the following, your problem may be solved.

Code
//$string =
htmlentities($string, ENT_QUOTES, 'ISO-8859-1');

Just add two slashes in front of the line.

Ümit Kenan Gönüllü
Joomla! Accredited Translator
IP: --   

Polish language
tommass
Group: Member
Post Group: Newbie
Posts: 5
Status:
THX!
Now I can write polish characters in language pack files and forum works.
But I still can't see them corectly...
IP: --   

Polish language
rol
Group: Member
Post Group: Newbie
Posts: 3
Status:
Quote From : umitkenan April 21, 2008, 8:24 pm
If you change 148th line of functions.php with the following, your problem may be solved.

Code
//$string =
htmlentities($string, ENT_QUOTES, 'ISO-8859-1');

Just add two slashes in front of the line.

Ümit Kenan Gönüllü
Joomla! Accredited Translator


Thanks !!!!!

I "added two slashes in front of the line" and this problem is solved.

Affter this I replace 'ISO-8859-1' to 'windows-1251' and problem is solved too.

Edited by rol : May 2, 2008, 12:45 pm
IP: --   

Polish language
le1t00
Group: Member
Post Group: Newbie
Posts: 33
Status:
Kurcze ;/ Czyli lipa z polskiego języka?
Someone have Polish language pack? If it work I can translate it :) Must be in iso-8859-2
IP: --   

Polish language
AirAvalanche10
Group: Member
Post Group: Newbie
Posts: 12
Status:
Nie ma polskiego tłumaczenia?Translation:Is not Polish translation?

-----------------------
I can't good english. I'm Polish :)
IP: --   

Polish language
Sammael
Group: Member
Post Group: Newbie
Posts: 37
Status:
Hi!

AirAvalanche10, you must wait. I am from Poland and I'm working on it. The project is... little death, and I have no so much time, but it will soon released. :)

Best regards,
Sammael
IP: --   

« Previous    Next »

Threaded Mode | Print  

1


Jump To :


Members who read this topic
, pulkit, jlhaslip, kab012345, Lewtheo, petarjak, Squealer, tommy, oxlo, noamh, rol, tommass, atsuki, pabloo, AreczeQ, conix, pone, Haviv, tsrx, ngaycuoithang2, umitkenan, daris, seaf2, rafio, le1t00, ricardorcb, XandQ7, WebTurk, knyspel, satanista, kinan, bnm, Pico4U, neoniak, dreaken, VasiliyRS, abdo, XemiX, cristrixy, francy, Sammael, AirAvalanche10, rickeymartin55, blakker, mmo02old1, Waldemar


Users viewing this topic
3 guests, 0 users.


All times are GMT. The time now is December 13, 2017, 3:27 pm.

  Powered By AEF 1.1.0 Preview © 2007-2011 AEF Group. All rights reservedQueries: 13  |  Page Created In:0.171