Welcome Guest. Please Login or Register  


You are here: Index > Advanced Electron Forums > Mods > Requests > Topic : need some mods help

A2 Hosting

News:

Group Message
Hello Guest,

Welcome to the AEF Board. AEF is getting better and better and is also becoming more popular.
Take a few seconds to Register, its free, and it inspires us to work harder and improve on whatever we can improve on.
Give us some feedback, and tell your buddies about AEF!

Thanks,
The AEF Team

2


Threaded Mode | Print  

need some mods help
nexgenforum
Group: Member
Post Group: Working Newbie
Posts: 65
Status:
@SAFAD so i think i ve to remove that mod called ADS IN TOPICS/POST.  It has bug i think. Ok no prob i ll do that. Thanks Safad bhai wer r u 4m? My name is usman.

@Chris Trixy Thanks u both for ur kind help.

PLZ solve my these probs:

1.  When guest is view a post with attachment i want to show a custom text in place of attachment is. Like in Hide links mod 'only registered users can acess link' like that.

2.  I want to change aef directory name to forum. What changes should i make?

-----------------------
DOMAINS HOSTING SSL WEBSITES
All in one place with Affordable prices
IP: --   

need some mods help
SAFAD
Group: Administrator
Post Group: Elite Member
Posts: 279
Status:
Admin -> User Group Permissions -> Guests -> Download Attachments (no)

and for your second issue, rename the folder to forum,
edit universal.php
and change

Code

$globals['url']
$globals['server_url']
$globals['mainfiles']
$globals['themesdir']
$globals['pluginsdir']
$globals['cachedir']

the last line (as its the old directory name) to the new name
if you don't know what exactly to change, PM me with the info above

-----------------------
Best Regards
Sadaoui "SAFAD" Abderrahim - Lead Developer
My Blog
IP: --   

need some mods help
nexgenforum
Group: Member
Post Group: Working Newbie
Posts: 65
Status:
@SAFAD bro u didnt understand my first query read it carefuly

When guest  views a post
with attachment i want to show
a custom text in place of
attachment is. Like in Hide links
mod.  I want to show this custom message 'only registered users can
access attachments' to guest.

If theres any code changing plz give it to me with proper instruction. Plz bro i want to modify it.

Edited by nexgenforum : April 4, 2012, 2:46 pm

-----------------------
DOMAINS HOSTING SSL WEBSITES
All in one place with Affordable prices
IP: --   

need some mods help
SAFAD
Group: Administrator
Post Group: Elite Member
Posts: 279
Status:
go to themes/default/posts_theme.php

search for
Code
    ' . (!empty($attachments[$post[$p]['pid']]) ? '<br /><br />-----------------------<br />' . implode('<br />', $attachments[$post[$p]['pid']]) : '') . '


replace with
Code


    ' . (!empty($attachments[$post[$p]['pid']]) ? '<br /><br />-----------------------<br />' . implode('<br />', $attachments[$post[$p]['pid']]) : 'you are not logged in') . '

enjoy


-----------------------
Best Regards
Sadaoui "SAFAD" Abderrahim - Lead Developer
My Blog
IP: --   

need some mods help
nexgenforum
Group: Member
Post Group: Working Newbie
Posts: 65
Status:
thanks buddy great work i ll make this change tomorrow Inshaallah

-----------------------
DOMAINS HOSTING SSL WEBSITES
All in one place with Affordable prices
IP: --   

need some mods help
nexgenforum
Group: Member
Post Group: Working Newbie
Posts: 65
Status:

@SAFAD bro i made following changes to universal.php as u said but this error comes "Unable to load the Themes settings file."

$globals['url'] = 'http://nexgen4m.freehostingcloud.com/forum';
$globals['sn'] = 'NEXGENFORUM';
$globals['board_email'] = 'nexgenforum@gmail.com';
$globals['server_url'] = '/chroot/home/nexgenmf/nexgen4m.freehostingcloud.com/html/forum';
$globals['mainfiles'] = '/chroot/home/nexgenmf/nexgen4m.freehostingcloud.com/html/forum/main';
$globals['themesdir'] = '/chroot/home/nexgenmf/nexgen4m.freehostingcloud.com/html/forum/themes' ;;
$globals['gzip'] = 1;
$globals['cookie_name'] = 'AEFCookies6297';
$globals['installed'] = '1';

currently i re-renamed to older name



-----------------------
DOMAINS HOSTING SSL WEBSITES
All in one place with Affordable prices
IP: --   

need some mods help
SAFAD
Group: Administrator
Post Group: Elite Member
Posts: 279
Status:
change this
Code


$globals['themesdir'] = '/chroot/home/nexgenmf/nexgen4m.freehostingcloud.com/html/forum/themes' ; ;;


to this
Code
$globals['themesdir'] = '/chroot/home/nexgenmf/nexgen4m.freehostingcloud.com/html/forum/themes' ; ;


-----------------------
Best Regards
Sadaoui "SAFAD" Abderrahim - Lead Developer
My Blog
IP: --   

need some mods help
nexgenforum
Group: Member
Post Group: Working Newbie
Posts: 65
Status:
Quote From : SAFAD April 4, 2012, 4:38 pm
go to themes/default/posts_theme.php

search for
Code
    ' . (!empty($attachments[$post[$p]['pid']]) ? '<br /><br />-----------------------<br />' . implode('<br />', $attachments[$post[$p]['pid']]) : '') . '


replace with
Code


    ' . (!empty($attachments[$post[$p]['pid']]) ? '<br /><br />-----------------------<br />' . implode('<br />', $attachments[$post[$p]['pid']]) : 'you are not logged in') . '

enjoy



Hi SAFAD bro i think there is some bug.  after making this modification the text "you are not logged in" display on all posts/topics even without attachments
plz help bro



-----------------------
DOMAINS HOSTING SSL WEBSITES
All in one place with Affordable prices
IP: --   

need some mods help
nexgenforum
Group: Member
Post Group: Working Newbie
Posts: 65
Status:
the code you mentioned to change is located at 2 places in posts_theme.php  one at line 517 something and second at line 1049
plz check it



-----------------------
DOMAINS HOSTING SSL WEBSITES
All in one place with Affordable prices
IP: --   

need some mods help
cristrixy
Group: Universal Moderator
Post Group: Working Member
Posts: 211
Status:
At the line 1049 is for:USER GROUPS AND IMAGES
PHP Code

 //If the user group has some images  as per Group
    
if ($post[$p]['image_count']) { 





-----------------------
:D
IP: --   

need some mods help
cristrixy
Group: Universal Moderator
Post Group: Working Member
Posts: 211
Status:
i just make a probe and i do not see nothing wrong .

If i'm logout i see the text "you have to login to see the attachments"
If login like member admin etc etc i see the file.
The code is good
PHP Code

 ' . (!empty($attachments[$post[$p]['pid']]) ? '<br /><br />-----------------------<br />' . implode('<br />', $attachments[$post[$p]['pid']]) : 'You have to login to see the attachm ents ') . ' 




-----------------------
:D
IP: --   

need some mods help
SAFAD
Group: Administrator
Post Group: Elite Member
Posts: 279
Status:
try replacing it with this one
Code

    ' . (!empty($attachments[$post[$p]['pid']]) ? ($logged_in ? '<br /><br />-----------------------<br />' . implode('<br />', $attachments[$post[$p]['pid']]) : 'You need to log in') : '') . '

and cristrixy, he probably meant that the old code showed that he should login on all topics, even the ones without attachments

-----------------------
Best Regards
Sadaoui "SAFAD" Abderrahim - Lead Developer
My Blog
IP: --   

need some mods help
nexgenforum
Group: Member
Post Group: Working Newbie
Posts: 65
Status:
Quote From : SAFAD April 6, 2012, 12:53 pm
try replacing it with this one
Code

    ' . (!empty($attachments[$post[$p]['pid']]) ? ($logged_in ? '<br /><br />-----------------------<br />' . implode('<br />', $attachments[$post[$p]['pid']]) : 'You need to log in') : '') . '

and cristrixy, he probably meant that the old code showed that he should login on all topics, even the ones without attachments



SAFAD bro this time nothing is displayed even on attachment post without login. see this direct link to attachment post

http://nexgen4m.freehostingcloud.com/aed/index.php?tid=24&ti tle=test


i m also attaching the my posts_theme.php file here


-----------------------
DOMAINS HOSTING SSL WEBSITES
All in one place with Affordable prices
IP: --   

need some mods help
cristrixy
Group: Universal Moderator
Post Group: Working Member
Posts: 211
Status:
:??: | :??:

Board Image


Board Image


Edited by cristrixy : April 6, 2012, 4:21 pm

-----------------------
:D
IP: --   

need some mods help
nexgenforum
Group: Member
Post Group: Working Newbie
Posts: 65
Status:
yeah i agree with u cris but in my case the text displays in all posts with or without attachment
I have attached file plz take a look

-----------------------
DOMAINS HOSTING SSL WEBSITES
All in one place with Affordable prices
IP: --   

« Previous    Next »

Threaded Mode | Print  

2


Jump To :


Members who read this topic
kumarullal, VasiliyRS, SAFAD, cristrixy, sachin, Sammael, ahmad, nexgenforum, donjava, scamsurvivors, HIMALAYA, tpiros, yogeshvashist98, ezinna, gaguns, tonky, Profiler, puw


Users viewing this topic
1 guests, 0 users.

A2 Hosting

All times are GMT. The time now is September 15, 2019, 2:24 pm.

  Powered By AEF 1.1.0 Preview © 2007-2011 AEF Group. All rights reservedQueries: 13  |  Page Created In:0.385